Forum software upgrade bug reports and change requests

Discussions about the forum and contents
FactualFran
Posts: 729
Joined: Sat Feb 21, 2015 2:29 pm

Re: Forum software upgrade bug reports and change requests

Post by FactualFran » Thu Jul 05, 2018 4:42 pm

LadyGeek wrote:
Thu Jul 05, 2018 3:43 pm
I tried quoting your post, but the BBCode interpreter could not handle the format you've shown. (Everything after the first BBCode resulted in an underlined link.) The BBCode displayed in your post is not what you've used. Also, I don't see the extra line breaks in your example post.
That's right, the BBCode displayed in my post is not exactly what I used. It has the form of what I used, plus something so that it would not be interpreted as BBCode, but would accurately display the form of what I wrote.
LadyGeek wrote:
Thu Jul 05, 2018 3:43 pm
As for modifying CSS, we don't have the resources to test the many, many browser and device configurations supported by this software. For this reason, we must stick with the "stock" configuration. It's not the best way to do things, but it works.

If this doesn't fix your problem, feel free to supply a few detailed examples in Please Try Out Test Posts Here and we'll work through them.
If you stick to the "stock" configuration, then please forward the problem report to the person responsible for the "stock" configuration.

An example is at the URL I posted. Here is the URL again: viewtopic.php?f=10&t=253203&newpost=4004280#p4004314

If you prefer the example to be in this post, here it is in a block quote (to make it distinct from the rest of the text I'm writing in this post).
Please read The Twelve Pillars of Wisdom Lessons We Should Have Learned before the Bear Market Arrived, but are Only Learning Now remarks that Bogle made in 2001 at a time much closer to what he did.
As I wrote in my previous post here, there are unexpected line breaks before and after the title of what is being linked to. The title should be inline. There is also an unexpected line drawn below the last line of the title of what is being linked to.

With an artificially shorten title, as in
Please read Not the title remarks that Bogle made in 2001 at a time much closer to what he did.
the title is inline, as it should be, but with the added, and in my opinion unnecessary, line below the title.

Choy
Posts: 361
Joined: Mon Sep 27, 2010 9:56 pm

[Feature Request] Add Apple iOS meta tags

Post by Choy » Thu Jul 19, 2018 11:14 pm

Can you add Apple meta tags to the site so that when a person using iOS saves the site to their home screen it opens in full screen mode as a standalone app?

Currently adding it to the home screen just opens the site in normal Safari mode.

https://developer.apple.com/library/arc ... aTags.html

User avatar
LadyGeek
Site Admin
Posts: 48030
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Jul 29, 2018 10:18 pm

^^^ Sorry for the delay to reply. I merged your post into the "requests" thread.

Thanks for the suggestion. Unfortunately, adding meta tags or other support specific to Apple, Android, etc. won't be implemented. Due to a very limited amount of resources, we need to stick with the "stock" released software.
Wiki To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
LadyGeek
Site Admin
Posts: 48030
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Wed Sep 26, 2018 8:29 pm

The forum software has been updated from phpBB 3.2.2 to 3.2.3, which is a maintenance release.

There is one change visible to readers:
More visible links to privacy policy and terms - Links to privacy policy and terms of use are prominently displayed in the footer.
Scroll to the bottom of the page and note the new entries under our disclaimer:
Wiki To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
randomizer
Posts: 1511
Joined: Sun Jul 06, 2014 3:46 pm

Re: Forum software upgrade bug reports and change requests

Post by randomizer » Sun Oct 14, 2018 5:08 am

Starting a week or two ago the notifications menu doesn't drop down on mobile for me anymore (tested on Chrome iOS and Safari iOS). I just see a triangle like in the screenshot. Works fine on desktop.

Image
87.5:12.5, EM tilt — HODL the course!

User avatar
Peculiar_Investor
Posts: 1110
Joined: Thu Oct 20, 2011 12:23 am
Location: Calgary, AB
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Peculiar_Investor » Sun Oct 14, 2018 8:11 am

randomizer wrote:
Sun Oct 14, 2018 5:08 am
Starting a week or two ago the notifications menu doesn't drop down on mobile for me anymore (tested on Chrome iOS and Safari iOS). I just see a triangle like in the screenshot. Works fine on desktop.

Image
I can confirm I'm seeing the same behaviour using Chrome on iOS 12.01.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
LadyGeek
Site Admin
Posts: 48030
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Oct 14, 2018 11:29 am

Perhaps this is related to the OS or browser?

I don't see this behavior on Android 8.1 with Chrome 69.0.3497.100. The notifications drop-down work as expected.
Wiki To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
Peculiar_Investor
Posts: 1110
Joined: Thu Oct 20, 2011 12:23 am
Location: Calgary, AB
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Peculiar_Investor » Sun Oct 14, 2018 12:59 pm

Don't think is OS or browser, but rather mobile device size. I can reproduce this using Chrome's Inspect Element tool if I set my device to iPhone 5/SE (320px wide) but it works properly on iPhone 6/7/8 (375px wide).
Peculiar_Investor wrote:
Sun Oct 14, 2018 8:11 am
I can confirm I'm seeing the same behaviour using Chrome on iOS 12.01.
Device is iPhone SE.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
randomizer
Posts: 1511
Joined: Sun Jul 06, 2014 3:46 pm

Re: Forum software upgrade bug reports and change requests

Post by randomizer » Sun Oct 14, 2018 2:28 pm

Peculiar_Investor wrote:
Sun Oct 14, 2018 12:59 pm
Don't think is OS or browser, but rather mobile device size. I can reproduce this using Chrome's Inspect Element tool if I set my device to iPhone 5/SE (320px wide) but it works properly on iPhone 6/7/8 (375px wide).
Peculiar_Investor wrote:
Sun Oct 14, 2018 8:11 am
I can confirm I'm seeing the same behaviour using Chrome on iOS 12.01.
Device is iPhone SE.
By jove I think you've got it!
87.5:12.5, EM tilt — HODL the course!

User avatar
mrc
Posts: 1197
Joined: Sun Jan 10, 2016 6:39 am

Re: Forum software upgrade bug reports and change requests

Post by mrc » Sun Oct 14, 2018 2:57 pm

randomizer wrote:
Sun Oct 14, 2018 2:28 pm
Peculiar_Investor wrote:
Sun Oct 14, 2018 12:59 pm
Don't think is OS or browser, but rather mobile device size. I can reproduce this using Chrome's Inspect Element tool if I set my device to iPhone 5/SE (320px wide) but it works properly on iPhone 6/7/8 (375px wide).
Peculiar_Investor wrote:
Sun Oct 14, 2018 8:11 am
I can confirm I'm seeing the same behaviour using Chrome on iOS 12.01.
Device is iPhone SE.
By jove I think you've got it!
Yep. I see the element disappear at 339 px and reappear at 340 px.
If it’s not long term it’s small talk

User avatar
randomizer
Posts: 1511
Joined: Sun Jul 06, 2014 3:46 pm

Re: Forum software upgrade bug reports and change requests

Post by randomizer » Sun Oct 14, 2018 3:24 pm

At least the workaround is easy enough. (Just rotate the phone.)
87.5:12.5, EM tilt — HODL the course!

User avatar
LadyGeek
Site Admin
Posts: 48030
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Oct 14, 2018 4:10 pm

mrc wrote:
Sun Oct 14, 2018 2:57 pm
Yep. I see the element disappear at 339 px and reappear at 340 px.
On a desktop with Chrome's Inspect Element tool in "Responsive mode", I see the element disappear at 350 px and reappear at 351 px.

Rotating the phone is a good workaround.

==================
Thanks to randomizer for finding the bug and the workaround, and to Peculiar_Investor for finding out what caused it.

My guess: This is a bug that will be fixed in the next software update. I'll investigate.
Wiki To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

Post Reply