Forum software upgrade bug reports and change requests

Discussions about the forum and contents
Mudpuppy
Posts: 5159
Joined: Sat Aug 27, 2011 2:26 am
Location: Sunny California

Re: Forum software upgrade bug reports and change requests

Post by Mudpuppy » Sat Aug 12, 2017 2:50 pm

azurekep wrote:
Sat Aug 12, 2017 2:31 pm
Is there a way for users to change the notification icon from red to something else?

Likewise with the red page icons that show up next to some threads?

The blue theme of Bogleheads is relaxing and conducive to good thought.

The red is alarming.
If you mark all your notifications as read, the icon goes back to blue. Likewise, if you mark all threads in a forum as read, the thread icon goes back to blue.

They're red to alert you to the fact there's something new. So they're being alarming on purpose.

azurekep
Posts: 670
Joined: Tue Jun 16, 2015 7:16 pm

Re: Forum software upgrade bug reports and change requests

Post by azurekep » Sat Aug 12, 2017 2:54 pm

Mudpuppy wrote:
Sat Aug 12, 2017 2:50 pm
azurekep wrote:
Sat Aug 12, 2017 2:31 pm
Is there a way for users to change the notification icon from red to something else?

Likewise with the red page icons that show up next to some threads?

The blue theme of Bogleheads is relaxing and conducive to good thought.

The red is alarming.
If you mark all your notifications as read, the icon goes back to blue. Likewise, if you mark all threads in a forum as read, the thread icon goes back to blue.

They're red to alert you to the fact there's something new. So they're being alarming on purpose.
Thanks. Your reply came up in Notifications like a fire alarm. So it does work. :mrgreen:

Geologist
Posts: 1082
Joined: Fri Jan 02, 2009 7:35 pm

Re: Forum software upgrade bug reports and change requests

Post by Geologist » Sat Aug 12, 2017 3:44 pm

prudent wrote:
Sat Aug 12, 2017 11:19 am
Geologist wrote:
Sat Aug 12, 2017 11:15 am
LadyGeek wrote:
Sat Aug 12, 2017 10:42 am
Geologist wrote:
Sat Aug 12, 2017 10:32 am
triceratop wrote:
Sat Aug 12, 2017 9:59 am


I don't see the number of notifications listed on the top toolbar anymore. Is that simply hidden when the number is zero, now, or is the number permanently hidden?
In addition, there also used to be a link to mark all notifications as read to dismiss them at the top of the list. Now you apparently have to go a separate window to dismiss them or you have to go to each one individually. In fact, I'm not clear on how to get rid of the notifications in the drop down list because selecting one (and going to that thread) doesn't dismiss it.
The number of notifications is inside the big red icon that appears to the right of the "Notifications" link.

Click on the Notifications icon. At the top of the drop-down menu (to the right of "Notifications") are two links: "Settings", and "Mark all read". Click on "Mark all read" to get rid of the notifications.
The "Mark all read" is only there now when there are new notifications. It was there when I saw the notification for your reply to my message here, but I jumped to this thread and now "mark all read" is gone.
Click Notifications -> See All (at the bottom of the dropdown list) -> in the upper right of the new page is an option for Mark All Notifications Read.
When I do this, I do get a response that all notifications read, but in the past, the notifications then disappeared from the dropdown list under the main dropdown spot (where it says "notifications private messages Geologist"). They don't now.

User avatar
iceport
Posts: 3223
Joined: Sat Apr 07, 2007 4:29 pm

Re: Forum software upgrade bug reports and change requests

Post by iceport » Sat Aug 12, 2017 4:41 pm

LadyGeek wrote:
Sat Aug 12, 2017 2:38 pm
iceport wrote:
Sat Aug 12, 2017 1:48 pm
I noticed the list of registered users who are logged in, previously visible at the bottom of each page, is no longer visible without being logged in. Is that a setting that will be reset, or is that just the way it will be after the upgrade?
I didn't change anything, so I'm guessing it's a new feature.
That's cool, thanks for the reply.

However, I didn't receive an email notification of your quote of my post, even though I have that notification option selected.
"Discipline matters more than allocation.” ─William Bernstein

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sat Aug 12, 2017 5:21 pm

My icon and email notifications are working. With no basis other than a hunch, I'm thinking the server is still catching up from the upgrade and didn't have time to send the notification out before you replied. If the problem continues, I'll dig into it further.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

gkaplan
Posts: 6946
Joined: Sat Mar 03, 2007 8:34 pm
Location: Portland, Oregon

Re: Forum software upgrade bug reports and change requests

Post by gkaplan » Sat Aug 12, 2017 6:09 pm

WoodSpinner wrote:
Sat Aug 12, 2017 11:35 am
Display of multi-page threads on the forum New Threads post is not working correctly. Text overwrites page count.

What's a New Threads post?
Gordon

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sat Aug 12, 2017 6:32 pm

I believe it's this link: New posts - click on "Quick links" to see the drop-down list.

You'll only see the problem when your browser has a narrow width which causes the page links to overlap. Here's a snapshot from the phpBB bug report

Image
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

gkaplan
Posts: 6946
Joined: Sat Mar 03, 2007 8:34 pm
Location: Portland, Oregon

Re: Forum software upgrade bug reports and change requests

Post by gkaplan » Sat Aug 12, 2017 6:50 pm

Okay. I use the Quick links drop-down menu to find the new posts or to search for my posts. I don't use any of the other options in the Quick links drop-down menu.
Gordon

gkaplan
Posts: 6946
Joined: Sat Mar 03, 2007 8:34 pm
Location: Portland, Oregon

Re: Forum software upgrade bug reports and change requests

Post by gkaplan » Sat Aug 12, 2017 7:48 pm

gkaplan wrote:
Sat Aug 12, 2017 6:50 pm
Okay. I use the Quick links drop-down menu to find the new posts or to search for my posts. I don't use any of the other options in the Quick links drop-down menu.
I should amend to say I rarely use the other options. On occasion, I have used them.
Gordon

User avatar
bertilak
Posts: 5490
Joined: Tue Aug 02, 2011 5:23 pm
Location: East of the Pecos, West of the Mississippi

Re: Forum software upgrade bug reports and change requests

Post by bertilak » Sat Aug 12, 2017 9:18 pm

One thing that no longer works: Use of the list feature without any [*] no longer gives a nice clean indentation. It supplies an unwanted [*] if you don't put one in yourself. Example:
  • This used to produce a simple indent without a bullet.
    It looks strange when you use multiple lines.

    Hello! What's that extraneous bullet doing up there?
Perhaps there is another trick to get simple indents.
Listen very carefully. I shall say this only once.

Mudpuppy
Posts: 5159
Joined: Sat Aug 27, 2011 2:26 am
Location: Sunny California

Re: Forum software upgrade bug reports and change requests

Post by Mudpuppy » Sat Aug 12, 2017 10:44 pm

bertilak wrote:
Sat Aug 12, 2017 9:18 pm
One thing that no longer works: Use of the list feature without any [*] no longer gives a nice clean indentation. It supplies an unwanted [*] if you don't put one in yourself. Example:
  • This used to produce a simple indent without a bullet.
    It looks strange when you use multiple lines.

    Hello! What's that extraneous bullet doing up there?
Perhaps there is another trick to get simple indents.
It looks like phpBB does not support the BBCode indent tag by default. Using the list tag was the work-around others used to replicate the indent behavior, but as you noted, it no longer is sufficient due to the bullet point on the first line.

The other option would be to use the quote tag, although that will make a box around the item you want indented. So it may be a matter of choosing between a bullet point or a quote box for the time being.

User avatar
bertilak
Posts: 5490
Joined: Tue Aug 02, 2011 5:23 pm
Location: East of the Pecos, West of the Mississippi

Re: Forum software upgrade bug reports and change requests

Post by bertilak » Sun Aug 13, 2017 11:07 am

LadyGeek wrote:
Sat Aug 12, 2017 12:33 pm
^^^ Nothing changed on how to do a list. The icons in the post editor changed, that's about it.
Actually, something HAS changed, something that I used a lot and think is quite important. See viewtopic.php?p=3490516#p3490516, just above.
Listen very carefully. I shall say this only once.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 11:32 am

OK, I see your point. Going by the "official" documentation: Generating lists

What you're doing is not supposed to work. I'm guessing the developers did a bunch of "clean up" for this major update and "fixed" it. Sorry, but there's nothing I can do.

Handling spaces and indents is not a strong point of the post editor. I do see some efforts to improve that, but for the next major release - which is a long way out.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
iceport
Posts: 3223
Joined: Sat Apr 07, 2007 4:29 pm

Re: Forum software upgrade bug reports and change requests

Post by iceport » Sun Aug 13, 2017 11:37 am

iceport wrote:
Sat Aug 12, 2017 4:41 pm
LadyGeek wrote:
Sat Aug 12, 2017 2:38 pm
iceport wrote:
Sat Aug 12, 2017 1:48 pm
I noticed the list of registered users who are logged in, previously visible at the bottom of each page, is no longer visible without being logged in. Is that a setting that will be reset, or is that just the way it will be after the upgrade?
I didn't change anything, so I'm guessing it's a new feature.
That's cool, thanks for the reply.

However, I didn't receive an email notification of your quote of my post, even though I have that notification option selected.
LadyGeek wrote:
Sat Aug 12, 2017 5:21 pm
My icon and email notifications are working. With no basis other than a hunch, I'm thinking the server is still catching up from the upgrade and didn't have time to send the notification out before you replied. If the problem continues, I'll dig into it further.
Just FYI, the email notification showed up this morning, almost a day later. FWIW...
"Discipline matters more than allocation.” ─William Bernstein

User avatar
Oicuryy
Posts: 1124
Joined: Thu Feb 22, 2007 10:29 pm

Re: Forum software upgrade bug reports and change requests

Post by Oicuryy » Sun Aug 13, 2017 11:46 am

bertilak wrote:
Sat Aug 12, 2017 9:18 pm
Perhaps there is another trick to get simple indents.
This code

Code: Select all

[list=none]
[*]Red
[*]Blue
[*]Yellow
[/list]
Gives this result
  • Red
  • Blue
  • Yellow
Ron
Money is fungible | Abbreviations and Acronyms

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 11:47 am

iceport wrote:
Sun Aug 13, 2017 11:37 am
Just FYI, the email notification showed up this morning, almost a day later. FWIW...
Thanks for letting me know. My hunch is confirmed. (The same thing happened when we moved from phpBB 3.0 to phpBB 3.1. It took several days for the server to get caught up.)
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 11:49 am

Oicuryy wrote:
Sun Aug 13, 2017 11:46 am
bertilak wrote:
Sat Aug 12, 2017 9:18 pm
Perhaps there is another trick to get simple indents.
This code

Code: Select all

[list=none]
[*]Red
[*]Blue
[*]Yellow
[/list]
Gives this result
  • Red
  • Blue
  • Yellow
Ron
Thanks! I'll see if I can find this documented somewhere.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
bertilak
Posts: 5490
Joined: Tue Aug 02, 2011 5:23 pm
Location: East of the Pecos, West of the Mississippi

Re: Forum software upgrade bug reports and change requests

Post by bertilak » Sun Aug 13, 2017 12:23 pm

Oicuryy wrote:
Sun Aug 13, 2017 11:46 am
bertilak wrote:
Sat Aug 12, 2017 9:18 pm
Perhaps there is another trick to get simple indents.
This code

Code: Select all

[list=none]
[*]Red
[*]Blue
[*]Yellow
[/list]
Gives this result
  • Red
  • Blue
  • Yellow
Ron
  • Woo-Hoo!
    Thanks.
(But I do think "none" makes a better default. Unless he "indent)

I went to Image to see if there were any more "list" options.

There are (but it didn't list "none"). Look at these:
  • disc
  • circle
  • square

I also found that there is more to the "size" option than tiny, small, and normal.
Listen very carefully. I shall say this only once.

longinvest
Posts: 2395
Joined: Sat Aug 11, 2012 8:44 am

Re: Forum software upgrade bug reports and change requests

Post by longinvest » Sun Aug 13, 2017 1:14 pm

Change request:
LadyGeek wrote:
Sun Aug 13, 2017 9:37 am
The icon to the left of the post author info* changes color if you've read the post.
Wouldn't it be better for the shape of the icon to change too? That would be useful for color-blind people. It would also be useful to those who sometimes read our forums on black-and-white devices (typical for electronic-paper screens).
Bogleheads investment philosophy | Lifelong Portfolio: 25% each of (domestic/international)stocks/(nominal/inflation-indexed)bonds | VCN/VXC/VAB/ZRR

Mudpuppy
Posts: 5159
Joined: Sat Aug 27, 2011 2:26 am
Location: Sunny California

Re: Forum software upgrade bug reports and change requests

Post by Mudpuppy » Sun Aug 13, 2017 1:35 pm

LadyGeek wrote:
Sun Aug 13, 2017 11:49 am
Oicuryy wrote:
Sun Aug 13, 2017 11:46 am
bertilak wrote:
Sat Aug 12, 2017 9:18 pm
Perhaps there is another trick to get simple indents.
This code

Code: Select all

[list=none]
[*]Red
[*]Blue
[*]Yellow
[/list]
Gives this result
  • Red
  • Blue
  • Yellow
Ron
Thanks! I'll see if I can find this documented somewhere.
Thanks for the find Ron. As far as I can tell, the "none" option is not documented in the official BBcode or phpBB documentation. I looked quite a bit last night to see if there was documentation of such an option, and all I found were various ways to get ordered lists. I wonder if BBCode supports passing through all of the list style options: https://www.w3schools.com/cssref/pr_list-style-type.asp

User avatar
Oicuryy
Posts: 1124
Joined: Thu Feb 22, 2007 10:29 pm

Re: Forum software upgrade bug reports and change requests

Post by Oicuryy » Sun Aug 13, 2017 2:01 pm

Mudpuppy wrote:
Sun Aug 13, 2017 1:35 pm
I wonder if BBCode supports passing through all of the list style options: https://www.w3schools.com/cssref/pr_list-style-type.asp
It looks like phpbb's implementation of bbcode does.
  1. one
  2. two
  3. three
Ron
Money is fungible | Abbreviations and Acronyms

User avatar
prudent
Moderator
Posts: 4516
Joined: Fri May 20, 2011 2:50 pm

Re: Forum software upgrade bug reports and change requests

Post by prudent » Sun Aug 13, 2017 2:23 pm

An observation: the previous software version was more readable on my phone - although the text in posts is still formatted to fit the screen width, in this version the text is meaningfully smaller.

boglesmind
Posts: 90
Joined: Sun Jan 05, 2014 1:07 pm

Re: Forum software upgrade bug reports and change requests

Post by boglesmind » Sun Aug 13, 2017 2:43 pm

prudent wrote:
Sun Aug 13, 2017 2:23 pm
An observation: the previous software version was more readable on my phone - although the text in posts is still formatted to fit the screen width, in this version the text is meaningfully smaller.
The forum main page has tiny fonts on phones running Android 7.x (Nexus 5, 6p etc ) and each thread appears to use a more readable font. Tried mobile version of the site as well as the desktop version on the phones and they look exactly the same using Chrome browser.

Boglesmind

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 2:47 pm

^^^ That's the home page screen, which is not affected by the software.

Currently, there's no mobile support. I'm working on that with the site owners, which is a long-standing request. (There's no need to ask further, which has already been done in several threads.)
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

boglesmind
Posts: 90
Joined: Sun Jan 05, 2014 1:07 pm

Re: Forum software upgrade bug reports and change requests

Post by boglesmind » Sun Aug 13, 2017 2:57 pm

LadyGeek wrote:
Sun Aug 13, 2017 2:47 pm
^^^ That's the home page screen, which is not affected by the software.

Currently, there's no mobile support. I'm working on that with the site owners, which is a long-standing request. (There's no need to ask further, which has already been done in several threads.)
Didn't know that. Thanks for the quick response. Is there a page that lists outstanding requests that we can browse, to prevent multiple requests for the same feature?

Boglesmind

retiredjg
Posts: 29767
Joined: Thu Jan 10, 2008 12:56 pm

Re: Forum software upgrade bug reports and change requests

Post by retiredjg » Sun Aug 13, 2017 3:14 pm

Not to rush you, but email notifications are still not working right.

I got a bunch from yesterday this morning, but am not receiving any today from posts today. Or maybe just since mid-morning, I'm not sure.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 3:16 pm

boglesmind wrote:
Sun Aug 13, 2017 2:57 pm
LadyGeek wrote:
Sun Aug 13, 2017 2:47 pm
^^^ That's the home page screen, which is not affected by the software.

Currently, there's no mobile support. I'm working on that with the site owners, which is a long-standing request. (There's no need to ask further, which has already been done in several threads.)
Didn't know that. Thanks for the quick response. Is there a page that lists outstanding requests that we can browse, to prevent multiple requests for the same feature?

Boglesmind
Sorry, no. A forum search is the only option (the "gear" icon in the top-right corner of the page).

To those who've posted in those threads, there's no need to bump them.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 3:24 pm

retiredjg wrote:
Sun Aug 13, 2017 3:14 pm
Not to rush you, but email notifications are still not working right.

I got a bunch from yesterday this morning, but am not receiving any today from posts today. Or maybe just since mid-morning, I'm not sure.
I asked mingstar (site owner and server admin) to look into it.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
G-Force
Posts: 266
Joined: Sun Sep 20, 2009 3:03 pm
Location: Florida
Contact:

Re: Forum software upgrade bug reports and change requests

Post by G-Force » Sun Aug 13, 2017 3:57 pm

I posted about this awhile ago an a separate thread but never received a response. viewtopic.php?f=3&t=211467

Can you fix the link to the touch icons so they reflect the boglehead log and not the apple logo? Thanks!

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 6:54 pm

Sure! It's fixed. See: Re: Incorrect Apple Touch Icons

This is why supporting devices requires a lot of testing and development resources. Apple does their own thing with icons.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

The Wizard
Posts: 10542
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun Aug 13, 2017 7:53 pm

LadyGeek wrote:
Sun Aug 13, 2017 2:47 pm
^^^ That's the home page screen, which is not affected by the software.

Currently, there's no mobile support. I'm working on that with the site owners, which is a long-standing request. (There's no need to ask further, which has already been done in several threads.)
Mobile device rendering is fine, no changes needed.
Sometimes I request desktop version on my smartphone and that works fine also...
Attempted new signature...

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun Aug 13, 2017 8:44 pm

retiredjg wrote:
Sat Aug 12, 2017 9:49 am
Your first whine.....not a change for the better. :(

Yucky.

Yes, I know you don't get any choice....
Sorry for the delay. Are you using Chrome? There's a bug report for blurry icons. Just to see if that's the problem, try using Firefox or Internet Explorer.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

retiredjg
Posts: 29767
Joined: Thu Jan 10, 2008 12:56 pm

Re: Forum software upgrade bug reports and change requests

Post by retiredjg » Mon Aug 14, 2017 7:02 am

LadyGeek wrote:
Sun Aug 13, 2017 8:44 pm
retiredjg wrote:
Sat Aug 12, 2017 9:49 am
Your first whine.....not a change for the better. :(

Yucky.

Yes, I know you don't get any choice....
Sorry for the delay. Are you using Chrome? There's a bug report for blurry icons. Just to see if that's the problem, try using Firefox or Internet Explorer.
First, an apology for the whine. :wink: I know you can't please everybody. Some people probably like this better. (eye rolling smilie face)

I'm using Safari, not chrome. The icons are not blurry.

I just think symbols instead of words is moving in the wrong direction. People who are not accustomed to this don't know what to do. When you tell people to "edit", you also have to add "use the pencil thing" in case they don't know. Now we have a quote symbol instead of a word, color, url, etc.

The addition of the strike through is a nice touch though.

User avatar
Peculiar_Investor
Posts: 930
Joined: Thu Oct 20, 2011 12:23 am
Location: Calgary, AB
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Peculiar_Investor » Mon Aug 14, 2017 7:26 am

WoodSpinner wrote:
Sat Aug 12, 2017 12:10 pm
I am also seeing a problem with the
  • formatting when I have multiple items.
LadyGeek wrote:
Sat Aug 12, 2017 12:33 pm
^^^ Nothing changed on how to do a list. The icons in the post editor changed, that's about it.

Hover you cursor over each button in the post editing toolbar to see its corresponding "tool tip".

You can practice here: Please Try Out Test Posts Here
LadyGeek wrote:
Sun Aug 13, 2017 11:32 am
OK, I see your point. Going by the "official" documentation: Generating lists

What you're doing is not supposed to work. I'm guessing the developers did a bunch of "clean up" for this major update and "fixed" it. Sorry, but there's nothing I can do.

Handling spaces and indents is not a strong point of the post editor. I do see some efforts to improve that, but for the next major release - which is a long way out.
Actually behind the scenes phpBB 3.2 introduced an all new BBCode engine powered by the s9e/TextFormatter library. From what I understand, the new BBCode engine is much stricter parsing syntax than previous versions, which may be the cause of problems where users had figured out "non-standard" syntax to implement their own "features".
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

vtMaps
Posts: 286
Joined: Tue Oct 14, 2008 12:05 pm
Location: central Vermont

Re: Forum software upgrade bug reports and change requests

Post by vtMaps » Mon Aug 14, 2017 9:04 am

Since the most recent upgrade I have not been receiving email notifications of new posts to threads that I subscribe to.

--vtMaps
The optimist proclaims that we live in the best of all possible worlds; and the pessimist fears this is true. --James Branch Cabell

User avatar
in_reality
Posts: 4097
Joined: Fri Jul 12, 2013 6:13 am

Re: Forum software upgrade bug reports and change requests

Post by in_reality » Mon Aug 14, 2017 9:11 am

The red highlight on the Notifications and PMs is great. I think newbies will notice PMs more. I know I do.

Love the look. Love the new icons.

It's actually human nature to infer social meaning to patterns. It's part-and-parcel of language acquisition and social understanding. So calling the quotes creepy (eyes) to me is just a natural extension of human nature. If one is thinking that though, perhaps it's more the nature of posing financial information (however non-identifiable) to a public website that is the underlying cause.
[60% US _ 26% DEV _ 14% EM] | (-16% LC _ +8% MC _ +8% SC) | [47% FND/VAL _ 40% MKT _ 7% MOM _ 6% REIT] | (+/- 5% or *25% rebalancing bands)

User avatar
House Blend
Posts: 4181
Joined: Fri May 04, 2007 1:02 pm

Re: Forum software upgrade bug reports and change requests

Post by House Blend » Mon Aug 14, 2017 9:35 am

retiredjg wrote:
Mon Aug 14, 2017 7:02 am
I just think symbols instead of words is moving in the wrong direction. People who are not accustomed to this don't know what to do. When you tell people to "edit", you also have to add "use the pencil thing" in case they don't know. Now we have a quote symbol instead of a word, color, url, etc.
Yes, I think icons in general are overused.

It would be better if there were some universally acknowledged symbols for various functions, but we're nowhere near that.

To give one current example, take the new icon that links to your Personal Messages. I still have no idea what symbolism the author had in mind, and hovering gave no additional clue as to the function.

If you were giving me a Rohrschach test, I'd say it's a head-on view of a car.

So, when I post in a thread to tell someone I sent them a personal message, I guess I need to tell them to click on the car thing.

retiredjg
Posts: 29767
Joined: Thu Jan 10, 2008 12:56 pm

Re: Forum software upgrade bug reports and change requests

Post by retiredjg » Mon Aug 14, 2017 9:55 am

I think it might be an inbox. Perhaps you are not old enough to know what that is?

User avatar
in_reality
Posts: 4097
Joined: Fri Jul 12, 2013 6:13 am

Re: Forum software upgrade bug reports and change requests

Post by in_reality » Mon Aug 14, 2017 10:02 am

House Blend wrote:
Mon Aug 14, 2017 9:35 am
retiredjg wrote:
Mon Aug 14, 2017 7:02 am
I just think symbols instead of words is moving in the wrong direction. People who are not accustomed to this don't know what to do. When you tell people to "edit", you also have to add "use the pencil thing" in case they don't know. Now we have a quote symbol instead of a word, color, url, etc.
Yes, I think icons in general are overused.

It would be better if there were some universally acknowledged symbols for various functions, but we're nowhere near that.

To give one current example, take the new icon that links to your Personal Messages. I still have no idea what symbolism the author had in mind, and hovering gave no additional clue as to the function.

If you were giving me a Rohrschach test, I'd say it's a head-on view of a car.

So, when I post in a thread to tell someone I sent them a personal message, I guess I need to tell them to click on the car thing.
Doesn't it say "Private Messages" next to it?

In any case, let your mouse hang over an icon for a second and it should give a text gloss on what it it. If you think it takes too long, I'm sure that it's configurable someplace. Some seem to not have a mouse over gloss, but they seem to be the ones with text next to them. Really seems fine to me.
[60% US _ 26% DEV _ 14% EM] | (-16% LC _ +8% MC _ +8% SC) | [47% FND/VAL _ 40% MKT _ 7% MOM _ 6% REIT] | (+/- 5% or *25% rebalancing bands)

User avatar
Peculiar_Investor
Posts: 930
Joined: Thu Oct 20, 2011 12:23 am
Location: Calgary, AB
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Peculiar_Investor » Mon Aug 14, 2017 10:19 am

in_reality wrote:
Mon Aug 14, 2017 10:02 am
Doesn't it say "Private Messages" next to it?
It depends on the device being used to visit the site. On desktop/tablet type devices there generally is explanatory text and helpful information in hover bubbles for most icons. On smartphones, the responsive design of the interface removes many of these "extras" to focus on what the phpBB designers have determined to be the minimal set of information required to convey the information.

It is left to the reader to determine whether the phpBB UI designers have gotten all the elements of the responsive design "correct". Based on discussions here and elsewhere (i.e. phpBB support forums), as expected this is often a personal viewpoint, some like more information, some like less and some accept that the phpBB UI designers have made good decisions. YMMV of course.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
House Blend
Posts: 4181
Joined: Fri May 04, 2007 1:02 pm

Re: Forum software upgrade bug reports and change requests

Post by House Blend » Mon Aug 14, 2017 10:24 am

in_reality wrote:
Mon Aug 14, 2017 10:02 am
House Blend wrote:
Mon Aug 14, 2017 9:35 am
To give one current example, take the new icon that links to your Personal Messages. I still have no idea what symbolism the author had in mind, and hovering gave no additional clue as to the function.

If you were giving me a Rohrschach test, I'd say it's a head-on view of a car.

So, when I post in a thread to tell someone I sent them a personal message, I guess I need to tell them to click on the car thing.
Doesn't it say "Private Messages" next to it?

In any case, let your mouse hang over an icon for a second and it should give a text gloss on what it it. If you think it takes too long, I'm sure that it's configurable someplace. Some seem to not have a mouse over gloss, but they seem to be the ones with text next to them. Really seems fine to me.
It and the bell icon for notifications don't have text hints when you hover, at least not on firefox. The "!" and quotemark and "pencil thing" do.

However, I neglected to notice the text of the URL that is available at the bottom of the firefox browser whenever one hovers over a link. That provides enough of a clue as to what the functionality might be:

Code: Select all

https://www.bogleheads.org/forum/ucp.php?i=pm&folder=inbox

User avatar
Oicuryy
Posts: 1124
Joined: Thu Feb 22, 2007 10:29 pm

Re: Forum software upgrade bug reports and change requests

Post by Oicuryy » Mon Aug 14, 2017 11:43 am

Peculiar_Investor wrote:
Mon Aug 14, 2017 7:26 am
Actually behind the scenes phpBB 3.2 introduced an all new BBCode engine powered by the s9e/TextFormatter library.
Who decided which bbcodes to use from that library? Did phpBB decide or did Bogleheads? Why was [table] not included?

Ron
Money is fungible | Abbreviations and Acronyms

User avatar
mrc
Posts: 878
Joined: Sun Jan 10, 2016 6:39 am
Location: right here

Re: Forum software upgrade bug reports and change requests

Post by mrc » Mon Aug 14, 2017 3:09 pm

vtMaps wrote:
Mon Aug 14, 2017 9:04 am
Since the most recent upgrade I have not been receiving email notifications of new posts to threads that I subscribe to.

--vtMaps
FWIW: Ditto for me. No email since Saturday evening, and when I reload a page, I have notifications.
A great challenge of life: Knowing enough to think you're doing it right, but not enough to know you're doing it wrong. — Neil deGrasse Tyson

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Mon Aug 14, 2017 4:04 pm

^^^ To the members reporting "no email notifications", I've turned the problem over to mingstar (server admin and site owner).
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Mon Aug 14, 2017 4:42 pm

The RSS (atom) feed is running fine. For Linux users, I have one more bug to fix: Re: The Forum is now "Feed friendly"
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Mon Aug 14, 2017 9:53 pm

^^^ It's fixed with python, see: Re: The Forum is now "Feed friendly"
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

User avatar
One Ping
Posts: 239
Joined: Thu Sep 24, 2015 4:53 pm

Re: Forum software upgrade bug reports and change requests

Post by One Ping » Tue Aug 15, 2017 10:30 am

What happened to the "Home" button at the bottom left of the thread pages?

There is just a "Board Index" button there now, but no "Home" button. I found being able to go directly from a thread page back to the home page extremely useful. I thought it was there right after the update, but now it's gone.

Any way to get it back?
"Re-verify our range to target ... one ping only."

Mudpuppy
Posts: 5159
Joined: Sat Aug 27, 2011 2:26 am
Location: Sunny California

Re: Forum software upgrade bug reports and change requests

Post by Mudpuppy » Tue Aug 15, 2017 10:36 am

One Ping wrote:
Tue Aug 15, 2017 10:30 am
What happened to the "Home" button at the bottom left of the thread pages?

There is just a "Board Index" button there now, but no "Home" button. I found being able to go directly from a thread page back to the home page extremely useful. I thought it was there right after the update, but now it's gone.

Any way to get it back?
Not sure if the admins can make that change, but here's a workaround for the meanwhile if you're using a keyboard. On most browsers, the "Home" key will take you to the top of the page. There's still the icon to go back to the main Bogleheads.org page at the top of the page.

User avatar
One Ping
Posts: 239
Joined: Thu Sep 24, 2015 4:53 pm

Re: Forum software upgrade bug reports and change requests

Post by One Ping » Tue Aug 15, 2017 10:46 am

Ah, I see. Thanks.

Not as convenient as having it at the bottom of the page, but it does get you there. So does the 'back' button on your browser but again ... not as convenient.
"Re-verify our range to target ... one ping only."

User avatar
LadyGeek
Site Admin
Posts: 39221
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Tue Aug 15, 2017 3:16 pm

^^^It was one of the changes made during the upgrade. (I forgot to do that and made the change the next day, sorry.)

On a mobile device, that lower area of the menu needs space to display the full subforum names (breadcrumbs...). Otherwise, the name gets truncated. Since the logo and header title already have links to the home page, it was redundant.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

Post Reply