Forum software upgrade bug reports and change requests

Discussions about the forum and contents
Post Reply
Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sat May 02, 2015 10:15 pm

Please put all requests and bug reports on this thread. We will be working to sort out everything we can and provide information or workarounds where we can't.

Questions on how to use or find features should go to this thread: What's new and changed in phpBB 3.1.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sat May 02, 2015 10:30 pm

BTW, we know the forum is slow. I believe this is due to some heavy, but temporary, reindexing going on in the background as a result of the upgrade. We'll keep you posted.

User avatar
Christine_NM
Posts: 2575
Joined: Tue Feb 20, 2007 1:13 am
Location: New Mexico

Re: Forum software upgrade bug reports and change requests

Post by Christine_NM » Sat May 02, 2015 10:50 pm

To the forum gods --

A private message sent to me on April 23 has reactivated itself (since the upgrade) and is showing as a new message no matter how many times I read it. I don't want to delete it, I just want to see "zero PM" on the banner heading when there are no new messages.

Thanks. Very low priority. All the font stuff reminds me of why I retired from software GUI design after 23 years. It finally got to me.
10% cash 45% stock 45% bond. Retired, w/d rate 1.5%

User avatar
#Cruncher
Posts: 2427
Joined: Fri May 14, 2010 2:33 am
Location: New York City
Contact:

Re: Forum software upgrade bug reports and change requests

Post by #Cruncher » Sat May 02, 2015 11:11 pm

Two problems regarding "# Replies" on the home page (www.bogleheads.org/index.php):
  • As pennstater2005 mentioned in this post, when I click on it, I get an error message:

    Code: Select all

    General Error
    SQL ERROR [ postgres ]
    ERROR: column "topic_replies" does not exist LINE 8: AND p.post_id = t.topic_last_post_id ORDER BY topic_replies...
    An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.
    Please notify the board administrator or webmaster: bhadmin@diehards.org
    This is more than academic. I like to order threads by number of replies to help decide which to respond to.
  • The count is one too high. I.e., it is the number of posts, not the number of replies.

bowtie
Posts: 302
Joined: Sun Jul 20, 2014 11:41 am

where is the symbol to enlarge?

Post by bowtie » Sat May 02, 2015 11:22 pm

Hi,
I used to click on the "A" in the top corner to enlarge the font size... is that no longer available?
I cannot find it anyplace now.
Thanks ....

madbrain
Posts: 4533
Joined: Thu Jun 09, 2011 5:06 pm
Location: San Jose, California

Re: Forum software upgrade bug reports and change requests

Post by madbrain » Sun May 03, 2015 12:13 am

Change request :

On my desktop Firefox 37 browser, I now get the tiny buttons where it used to say "report" and "quote".
The new buttons are not intuitive to me. I suppose they might make sense on a mobile browser with limited screen real estate. But they don't make sense on my triple screen 10 million pixel desktop.

It would be nice to get those old buttons back for desktops & large screens.
Even on mobile, I don't really care for the new smaller buttons, but YMMV.

madbrain
Posts: 4533
Joined: Thu Jun 09, 2011 5:06 pm
Location: San Jose, California

Re: Forum software upgrade bug reports and change requests

Post by madbrain » Sun May 03, 2015 12:23 am

Another issue, which is more annoying, and a regression :

When maximizing/widening a browser window containing a bogleheads.org thread, such as this one, There are now wide blank margins on the left and right, which didn't use to be there.

I can make these margins disappear by enlarging the font, but that misses the point - I can't read utilize the screen efficiently that way, which I used to be able to do.

These margins only seem to be appear when the browser window is wider than about 60% of my screen with, which is 2560 pixels.
This is with Firefox 37 on Windows. I just tried in Chrome and the same behavior occurs, but worse.

User avatar
BrandonBogle
Posts: 1907
Joined: Mon Jan 28, 2013 11:19 pm

Re: Forum software upgrade bug reports and change requests

Post by BrandonBogle » Sun May 03, 2015 12:50 am

I must be missing it somewhere, but how do I switch to a "Desktop View" if I don't want to use the mobile view? The formatting is off on my phone and I was comfortable just using the desktop site for my browsing and commentating. I hope this is a semi-permanent setting as I do 90% of my browsing and 80% of my posting from my phone.

Professor Emeritus
Posts: 2628
Joined: Mon Aug 13, 2012 6:43 am

Problems with website

Post by Professor Emeritus » Sun May 03, 2015 12:56 am

I can post a rep;y to a topic but not to a post and the quote feature is not working. tried three different machines
Last edited by Professor Emeritus on Sun May 03, 2015 1:06 am, edited 1 time in total.

dolphinsaremammals
Posts: 2094
Joined: Tue Jul 22, 2014 4:18 pm

Re: Problems with website

Post by dolphinsaremammals » Sun May 03, 2015 1:03 am

Plus, those icons are not as intelligible as English. It shouldn't be a guessing game to figure out how to quote a post or what the heck ! is supposed to mean.

I am constantly astonished at how user interfaces everywhere degrade. It's like everything that is known about them has been lost to the collective memory except for us old relics.

(Probably the worse currently is the tendency to replace search boxes with the word Search with no apparent place to type in the query until eventually it dawns in the user that the way to go is to click Search. Non-obvious, people.)
Last edited by dolphinsaremammals on Sun May 03, 2015 1:07 am, edited 1 time in total.

denovo
Posts: 3524
Joined: Sun Oct 13, 2013 1:04 pm

Re: Problems with website

Post by denovo » Sun May 03, 2015 1:06 am

Professor Emeritus wrote:I can post a rep;y to a topic but not to a post and the quote feature is not working. tried thee different machines


On the right edge of my post there's a box that looks like " that you use to quote, odd if it's not showing on your interface.

Professor Emeritus
Posts: 2628
Joined: Mon Aug 13, 2012 6:43 am

Re: Problems with website

Post by Professor Emeritus » Sun May 03, 2015 1:07 am

denovo wrote:
Professor Emeritus wrote:I can post a rep;y to a topic but not to a post and the quote feature is not working. tried thee different machines


On the right edge of my post there's a box that looks like " that you use to quote, odd if it's not showing on your interface.


found it
thank you

I do not see how to reply to a post without quoting.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 1:22 am

#Cruncher wrote:Two problems regarding "# Replies" on the home page (www.bogleheads.org/index.php):
  • As pennstater2005 mentioned in this post, when I click on it, I get an error message:
    ...
  • The count is one too high. I.e., it is the number of posts, not the number of replies.

I fixed both issues.

denovo
Posts: 3524
Joined: Sun Oct 13, 2013 1:04 pm

Re: Problems with website

Post by denovo » Sun May 03, 2015 1:27 am

If you're not going to quote, on the very bottom there is a post reply button.

Professor Emeritus
Posts: 2628
Joined: Mon Aug 13, 2012 6:43 am

Re: Problems with website

Post by Professor Emeritus » Sun May 03, 2015 1:33 am

denovo wrote:If you're not going to quote, on the very bottom there is a post reply button.

I think before you could reply to a specific post.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: where is the symbol to enlarge?

Post by Alex Frakt » Sun May 03, 2015 1:33 am

bowtie wrote:Hi,
I used to click on the "A" in the top corner to enlarge the font size... is that no longer available?
I cannot find it anyplace now.
Thanks ....

It's gone. You have to use the browser to change font sizes now. CTRL+ (or Option+) will usually make the font larger. CTRL- (or Option-) makes it smaller.

Professor Emeritus
Posts: 2628
Joined: Mon Aug 13, 2012 6:43 am

Re: Forum software upgrade bug reports and change requests

Post by Professor Emeritus » Sun May 03, 2015 1:36 am

my apologies , I did not see this thread

viewtopic.php?f=3&t=165039&newpost=2479205#p2479187

May I suggest that for the moment you set it so this thread is always at the top of the list?

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 1:37 am

Christine_NM wrote:A private message sent to me on April 23 has reactivated itself (since the upgrade) and is showing as a new message no matter how many times I read it. I don't want to delete it, I just want to see "zero PM" on the banner heading when there are no new messages.

Go to your Inbox and click the link towards the top right that says "Mark all messages read". This worked for me.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 1:42 am

Professor Emeritus wrote:my apologies , I did not see this thread

viewtopic.php?f=3&t=165039&newpost=2479205#p2479187

May I suggest that for the moment you set it so this thread is always at the top of the list?

I merged your thread here. This thread is currently pinned to the top of this subforum. Depending on how things go, I may add an announcement to the site homepage as well.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 1:43 am

madbrain wrote:Change request :

On my desktop Firefox 37 browser, I now get the tiny buttons where it used to say "report" and "quote".
The new buttons are not intuitive to me. I suppose they might make sense on a mobile browser with limited screen real estate. But they don't make sense on my triple screen 10 million pixel desktop.

It would be nice to get those old buttons back for desktops & large screens.
Even on mobile, I don't really care for the new smaller buttons, but YMMV.

We will be looking into this. I also prefer text labels where possible.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 1:49 am

A couple of issues that came up on the announcement thread.

Making the header text (not just the logo) a link to the homepage again on the list. Using the full screen width may not be, but we will test making it flush left. I find the double margins highly annoying.

As you may have guessed, the primary reason for the upgrade is to better accommodate mobile devices, which now make up maybe 1/3 of our views and is constantly growing. It's a very big improvement for anyone using phones and tablets, so we feel it's worth what we hope will be no more than a very minor loss for those using a desktop or larger laptop.

Alex Frakt
Founder
Posts: 10730
Joined: Fri Feb 23, 2007 1:06 pm
Location: Chicago
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Alex Frakt » Sun May 03, 2015 2:38 am

nisiprius wrote:
prudent wrote:
rob wrote:... the bogleheads label on the top is no longer a hot link back to the main page.
The square logo to the left of the word "Bogleheads" works for that.
Previously, both the logo and the text were links to the main page. Now it's only the logo. Right now it seems very burdensome to move the mouse that extra inch to the left but I expect I'll adjust to it.

I half-fixed this one. The word Bogleheads is a link again, but the subhead is not. It's a stylesheet issue - making the subhead a link turns it blue which makes it nearly invisible on the blue background - so it will have to wait until we get around to cloning the default style so we can make changes.

User avatar
digarei
Posts: 680
Joined: Sat Jul 05, 2014 1:41 am
Location: Sacramento
Contact:

Re: where is the symbol to enlarge?

Post by digarei » Sun May 03, 2015 3:40 am

Alex Frakt wrote:
bowtie wrote:Hi,
I used to click on the "A" in the top corner to enlarge the font size... is that no longer available?
I cannot find it anyplace now.
Thanks ....

It's gone. You have to use the browser to change font sizes now. CTRL+ (or Option+) will usually make the font larger. CTRL- (or Option-) makes it smaller.

iPad 1 user here. To my knowledge there is no Ctrl key combo that resizes fonts within the Safari browser... touch only.

The text does seem almost super-sized. I can make it larger (zoom out) by index-thumb spreading---but for reading comfort it needs to be smaller.

If there are other iPad users out there that have resolved this, please post! Downloading another popular browser is not an option -- the iPad 1 is permanently moored to iOS 5.

------------------------
Different Item -- BLUE BUTTON LINKS gone? -- In the previous software version there was a clickable link (in the form of a little blue button) displayed under user name/location in posts by forum members with personal websites. I tried this function earlier tonight for the first time but I could not identify a link when examining my own posts.
Connect with Bogleheads in Northern California! Click the link under my user info/avatar.

b4real
Posts: 101
Joined: Wed Mar 05, 2014 6:19 am

Re: Forum software upgrade bug reports and change requests

Post by b4real » Sun May 03, 2015 5:31 am

RSS has stopped working. From a newsreader it does nothing. If clicking on the link https://www.bogleheads.org/rss/ it gives the error:
"General Error
Illegal use of $_SERVER. You must use the request class or request_var() to access input data. Found in /usr/local/www/www.bogleheads.org/htdocs/rss/index.php on line 67. This error message was generated by deactivated_super_global."

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 6:21 am

I use my Nexus 5 smartphone on the forum most of the time nowadays, so I was pleasantly surprised this morning to see the modernized mobile format.
It's easy enough to click on the new icons here & there to find out what they do.

One small request: we're wasting too much space at the top of each post. The field containing poster's name, exclamation point, and quote mark can be compressed down to almost half its present height, getting the poster's name closer to the title of the post...
Attempted new signature...

Bracket
Posts: 414
Joined: Sun Mar 10, 2013 7:50 pm

Re: Forum software upgrade bug reports and change requests

Post by Bracket » Sun May 03, 2015 6:43 am

BrandonBogle wrote:I must be missing it somewhere, but how do I switch to a "Desktop View" if I don't want to use the mobile view? The formatting is off on my phone and I was comfortable just using the desktop site for my browsing and commentating. I hope this is a semi-permanent setting as I do 90% of my browsing and 80% of my posting from my phone.


I'm having the exact same issue on my iPhone.

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 6:51 am

Another bug is a carryover bug from before.
Sometimes a thread will be two pages in length, 51 to 100 posts.
I'll click on First unread post, and it takes me to the top of page two, post 51, when in fact, there were a few posts at toward the bottom of page 1 that I'd not read.
Similar for 3, 4, 5, ...N-page threads...
Attempted new signature...

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 6:55 am

Bracket wrote:
BrandonBogle wrote:I must be missing it somewhere, but how do I switch to a "Desktop View" if I don't want to use the mobile view? The formatting is off on my phone and I was comfortable just using the desktop site for my browsing and commentating. I hope this is a semi-permanent setting as I do 90% of my browsing and 80% of my posting from my phone.


I'm having the exact same issue on my iPhone.

That's a browser-dependent option.
In Chrome on my Nexus 5, I have a three-dot menu in upper right of screen.
In that dropdown, I can select "Request desktop site" if I want...
Attempted new signature...

Bracket
Posts: 414
Joined: Sun Mar 10, 2013 7:50 pm

Re: Forum software upgrade bug reports and change requests

Post by Bracket » Sun May 03, 2015 7:20 am

The Wizard wrote:
Bracket wrote:
BrandonBogle wrote:I must be missing it somewhere, but how do I switch to a "Desktop View" if I don't want to use the mobile view? The formatting is off on my phone and I was comfortable just using the desktop site for my browsing and commentating. I hope this is a semi-permanent setting as I do 90% of my browsing and 80% of my posting from my phone.


I'm having the exact same issue on my iPhone.

That's a browser-dependent option.
In Chrome on my Nexus 5, I have a three-dot menu in upper right of screen.
In that dropdown, I can select "Request desktop site" if I want...



I tried doing this in Safari and then downloaded Chrome to my phone and still no luck. Still displaying the mobile version despite pressing "show desktop view." Maybe it's an iPhone issue. Very frustrating.

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 7:35 am

Bracket wrote:
The Wizard wrote:That's a browser-dependent option.
In Chrome on my Nexus 5, I have a three-dot menu in upper right of screen.
In that dropdown, I can select "Request desktop site" if I want...



I tried doing this in Safari and then downloaded Chrome to my phone and still no luck. Still displaying the mobile version despite pressing "show desktop view." Maybe it's an iPhone issue. Very frustrating.

Ok, I just tried requesting desktop site myself and it failed.
So it's a forum s/w issue.
It queries the device initially to find out what it is, but right now changes are disallowed, it seems...
Attempted new signature...

dolphinsaremammals
Posts: 2094
Joined: Tue Jul 22, 2014 4:18 pm

Re: Forum software upgrade bug reports and change requests

Post by dolphinsaremammals » Sun May 03, 2015 7:55 am

madbrain wrote:Change request :

On my desktop Firefox 37 browser, I now get the tiny buttons where it used to say "report" and "quote".
The new buttons are not intuitive to me. I suppose they might make sense on a mobile browser with limited screen real estate. But they don't make sense on my triple screen 10 million pixel desktop.

It would be nice to get those old buttons back for desktops & large screens.
Even on mobile, I don't really care for the new smaller buttons, but YMMV.


The size is not nice, but even worse is the move to meaningless symbols away from English. It's not like the forum has to be intelligible to people who don't speak English.

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 8:53 am

Prior to the change, I found it useful to see the most recent poster in a thread along with the number of posts in that thread.
See if you can add that info back on the right side of each thread listing...
Attempted new signature...

Bracket
Posts: 414
Joined: Sun Mar 10, 2013 7:50 pm

Re: Forum software upgrade bug reports and change requests

Post by Bracket » Sun May 03, 2015 9:23 am

The Wizard wrote:Prior to the change, I found it useful to see the most recent poster in a thread along with the number of posts in that thread.
See if you can add that info back on the right side of each thread listing...


I can see all this on my desktop, but some of it is now on the left. On my iPhone I can see the number of replies, as well as who posted last, but I CANNOT see who the Original Poster is. So say I'm scrolling down looking to read anything posted by Larry Swedroe or Nisiprius I can't do so without opening each individual thread and looking to see whose name is above the first post. I love this forum and appreciate the hard work that goes into it and hate to complain, but not seeing the OP is kind of, well, bad. (I also don't see any avatars on the mobile version either but that's not so important)

Hopefully this can be addressed because the inability to browse this forum on my phone is to me a crisis of the highest order!

User avatar
BrandonBogle
Posts: 1907
Joined: Mon Jan 28, 2013 11:19 pm

Re: Forum software upgrade bug reports and change requests

Post by BrandonBogle » Sun May 03, 2015 9:32 am

The Wizard wrote:One small request: we're wasting too much space at the top of each post. The field containing poster's name, exclamation point, and quote mark can be compressed down to almost half its present height, getting the poster's name closer to the title of the post...


Not that I think Alex wants to have a custom design for this, but I wouldn't be opposed if the "signature" of the user is put up there instead of the bottom of the post on the mobile view. This can "fill in" that space and reclaim space overall that was used by the signature below the post.

The Wizard
Posts: 11096
Joined: Tue Mar 23, 2010 1:45 pm
Location: Reading, MA

Re: Forum software upgrade bug reports and change requests

Post by The Wizard » Sun May 03, 2015 9:37 am

Bracket wrote:
The Wizard wrote:Prior to the change, I found it useful to see the most recent poster in a thread along with the number of posts in that thread.
See if you can add that info back on the right side of each thread listing...


I can see all this on my desktop, but some of it is now on the left. On my iPhone I can see the number of replies, as well as who posted last, but I CANNOT see who the Original Poster is. So say I'm scrolling down looking to read anything posted by Larry Swedroe or Nisiprius I can't do so without opening each individual thread and looking to see whose name is above the first post. I love this forum and appreciate the hard work that goes into it and hate to complain, but not seeing the OP is kind of, well, bad. (I also don't see any avatars on the mobile version either but that's not so important)

Hopefully this can be addressed because the inability to browse this forum on my phone is to me a crisis of the highest order!

That's odd.
I've an Android smartphone in View New Posts mode.
It does display the OP for each thread, but not the most recent poster...
Attempted new signature...

User avatar
LadyGeek
Site Admin
Posts: 41552
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun May 03, 2015 9:51 am

b4real wrote:RSS has stopped working. From a newsreader it does nothing. If clicking on the link https://www.bogleheads.org/rss/ it gives the error:
"General Error
Illegal use of $_SERVER. You must use the request class or request_var() to access input data. Found in /usr/local/www/www.bogleheads.org/htdocs/rss/index.php on line 67. This error message was generated by deactivated_super_global."

Thanks, it's fixed. RSS feeds now render in Firefox's "Live Bookmarks".
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

Bracket
Posts: 414
Joined: Sun Mar 10, 2013 7:50 pm

Re: Forum software upgrade bug reports and change requests

Post by Bracket » Sun May 03, 2015 10:31 am

The Wizard wrote:
Bracket wrote:
The Wizard wrote:Prior to the change, I found it useful to see the most recent poster in a thread along with the number of posts in that thread.
See if you can add that info back on the right side of each thread listing...


I can see all this on my desktop, but some of it is now on the left. On my iPhone I can see the number of replies, as well as who posted last, but I CANNOT see who the Original Poster is. So say I'm scrolling down looking to read anything posted by Larry Swedroe or Nisiprius I can't do so without opening each individual thread and looking to see whose name is above the first post. I love this forum and appreciate the hard work that goes into it and hate to complain, but not seeing the OP is kind of, well, bad. (I also don't see any avatars on the mobile version either but that's not so important)

Hopefully this can be addressed because the inability to browse this forum on my phone is to me a crisis of the highest order!

That's odd.
I've an Android smartphone in View New Posts mode.
It does display the OP for each thread, but not the most recent poster...



You're right, if I go to View New Posts mode I can see the OP, but not the most recent poster. I just never knew about the existence of New Post Mode. It was never necessary before and I never used it. So I guess I have to choose whether to see the OP or the last poster, rather than both as it used to be.

Basically on my desktop I see everything, so four columns when looking at the list of threads. On the iPhone when looking at the list of threads I now only get one column, the other three are cut off. Some of that info is now in the one column, and some of it is not. And some of it is there but sort of crammed in. Like the thumbs up for "support this site" is moved from the top right to the top left and is now on top of, and obscuring, the "Home" link. The wiki link (little house icon) from the top right is now on top of the "Board Index" link on the left and all I can see is "Board... " with half a house icon right on top of it. Or maybe the half house icon is the Home icon, I don't know. Something is not quite right though.

I wonder if other iphone users are seeing the same.

User avatar
midareff
Posts: 5091
Joined: Mon Nov 29, 2010 10:43 am
Location: Biscayne Bay, South Florida

Re: Forum software upgrade bug reports and change requests

Post by midareff » Sun May 03, 2015 10:38 am

on the .org page the listing of threads has changed fonts. It changed on Android using Chrome and Firefox and on Windows using IE10 and Firefox. It looks like a change from Arial to either Calibri or New Times Roman. It comes across very difficult to read in IE10 .. please consider this a kind request to go back to the previous font.

Thanks/

User avatar
Peculiar_Investor
Posts: 973
Joined: Thu Oct 20, 2011 12:23 am
Location: Calgary, AB
Contact:

Re: Forum software upgrade bug reports and change requests

Post by Peculiar_Investor » Sun May 03, 2015 10:46 am

Bracket wrote:Like the thumbs up for "support this site" is moved from the top right to the top left and is now on top of, and obscuring, the "Home" link. The wiki link (little house icon) from the top right is now on top of the "Board Index" link on the left and all I can see is "Board... " with half a house icon right on top of it. Or maybe the half house icon is the Home icon, I don't know. Something is not quite right though.

I wonder if other iphone users are seeing the same.

I noticed this as well on my iPhone 5.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

sport
Posts: 6123
Joined: Tue Feb 27, 2007 3:26 pm
Location: Cleveland, OH

Re: Forum software upgrade bug reports and change requests

Post by sport » Sun May 03, 2015 11:07 am

When I click on "view your posts", it shows which threads have new posts added since the last time I saw them, as it is supposed to. However, when I view one of those threads, and then use the back button to go back to the list, it still shows that thread as having new posts, even though I just looked at it. I now have to refresh the page to get a correct status indication. Previously, when I used the back button, the correct status was shown.

User avatar
BrandonBogle
Posts: 1907
Joined: Mon Jan 28, 2013 11:19 pm

Re: Forum software upgrade bug reports and change requests

Post by BrandonBogle » Sun May 03, 2015 11:18 am

I just wanted to add that while we are posting differences we are seeing and suggestions or tidbits, we are very, very appreciative of everything you do for the site and us Bogleheads! We thank you for your hard work and dedication! :sharebeer

User avatar
sometimesinvestor
Posts: 1165
Joined: Wed May 13, 2009 6:54 am

Re: Forum software upgrade bug reports and change requests

Post by sometimesinvestor » Sun May 03, 2015 12:25 pm

appreciate the efforts. Today the site took a long time to load as did getting/loading to other articles by clicking on links. Is it a lot of people on site (Its sunday) or some bigger problem?

User avatar
TomatoTomahto
Posts: 6932
Joined: Mon Apr 11, 2011 1:48 pm

Re: Forum software upgrade bug reports and change requests

Post by TomatoTomahto » Sun May 03, 2015 12:47 pm

Alex Frakt wrote:As you may have guessed, the primary reason for the upgrade is to better accommodate mobile devices, which now make up maybe 1/3 of our views and is constantly growing. It's a very big improvement for anyone using phones and tablets, so we feel it's worth what we hope will be no more than a very minor loss for those using a desktop or larger laptop.

And ironically, since I dislike using my iPad in Portrait mode, I'm resigned to switching to using BH only on my desktop now because of the font issue. Btw, iPad portrait mode is only a partial work-around, but it improves browsing. All in all, my desktop will add BH to Quicken as its reason(s) for existence.

Is the slowness still a side-effect of indexing activity previously referred to?

User avatar
LadyGeek
Site Admin
Posts: 41552
Joined: Sat Dec 20, 2008 5:34 pm
Location: Philadelphia
Contact:

Re: Forum software upgrade bug reports and change requests

Post by LadyGeek » Sun May 03, 2015 1:22 pm

I'm fairly sure that the slowness is caused by the indexing activity. The upgrade zeroes out everything, so they must be rebuilt from scratch.

Indexes are used for many things, such as keeping track of posts you viewed ("View your posts"). The forum's search engine also uses indexes.

The last major upgrade we did (October 2011) took several days to catch up.
To some, the glass is half full. To others, the glass is half empty. To an engineer, it's twice the size it needs to be.

mingstar
Founder
Posts: 144
Joined: Sun Mar 11, 2007 7:35 am

Re: Forum software upgrade bug reports and change requests

Post by mingstar » Sun May 03, 2015 1:49 pm

Alex Frakt wrote:BTW, we know the forum is slow. I believe this is due to some heavy, but temporary, reindexing going on in the background as a result of the upgrade. We'll keep you posted.


I'm going to try using 'memcache' for caching the phpBB session data and search results, etc. I don't know if it will make any difference but it's worth a try.

I'm going to turn it on in a few minutes so you may have to authenticate again.

Larry

User avatar
jhfenton
Posts: 2263
Joined: Sat Feb 07, 2015 11:17 am
Location: Ohio

Re: Forum software upgrade bug reports and change requests

Post by jhfenton » Sun May 03, 2015 1:52 pm

madbrain wrote:Another issue, which is more annoying, and a regression :

When maximizing/widening a browser window containing a bogleheads.org thread, such as this one, There are now wide blank margins on the left and right, which didn't use to be there.

I can make these margins disappear by enlarging the font, but that misses the point - I can't read utilize the screen efficiently that way, which I used to be able to do.

These margins only seem to be appear when the browser window is wider than about 60% of my screen with, which is 2560 pixels.
This is with Firefox 37 on Windows. I just tried in Chrome and the same behavior occurs, but worse.

This is the case for me as well, though it is fairly standard (and often annoying behavior) on the web. I have a 4K monitor, and maximizing the window results in the website occupying the the middle 45% of the screen, with 27% blank on the left and 27% blank on the right. If I dock the window to half the screen width, then the website almost fills the window. I'm not sure how it would look, though, to read across the entire screen. The eye doesn't like to track lines of text that long.

More graphically-oriented websites, though, need to start accommodating WQHD and 4K screens. At this point, few do.

User avatar
tfb
Posts: 7736
Joined: Mon Feb 19, 2007 5:46 pm
Contact:

Re: Forum software upgrade bug reports and change requests

Post by tfb » Sun May 03, 2015 2:01 pm

mingstar wrote:I'm going to try using 'memcache' for caching the phpBB session data and search results, etc. I don't know if it will make any difference but it's worth a try.

Just got this error but it went away on refresh.

Could not find required extension [memcache] for the ACM module memcache.
Harry Sit, taking a break from the forums.

User avatar
whaleknives
Posts: 1210
Joined: Sun Jun 24, 2012 7:19 pm

Re: Forum software upgrade bug reports and change requests

Post by whaleknives » Sun May 03, 2015 2:02 pm

Haven't seen this mentioned so far: In the new Quick links>Your posts selection, the page icon is not red indicating unread posts, although the Forum page Topic list icons are red, and there is an "unread posts" icon.
Last edited by whaleknives on Sun May 03, 2015 2:03 pm, edited 1 time in total.
"I'm an indexer. I own the market. And I'm happy." (John Bogle, "BusinessWeek", 8/17/07) ☕ Maritime signal flag W - Whiskey: "I require medical assistance."

User avatar
Leesbro63
Posts: 4902
Joined: Mon Nov 08, 2010 4:36 pm

Re: Forum software upgrade bug reports and change requests

Post by Leesbro63 » Sun May 03, 2015 2:02 pm

I really miss the "View Your Posts" tab in the upper left. Now you have to go through 2 steps via "Quick Links". But I do recognize that you guys are volunteers so I won't forget to say thank you for trying to improve what might be the most valuable financial tool in the world. For FREE.

User avatar
TomatoTomahto
Posts: 6932
Joined: Mon Apr 11, 2011 1:48 pm

Re: Forum software upgrade bug reports and change requests

Post by TomatoTomahto » Sun May 03, 2015 2:13 pm

Further to Leesbro63's post, I don't want my whiny posts about font size to suggest anything but appreciation for the site, its many knowledgable posters, and the hard work and performance of its volunteer staff.

Post Reply