Problem with uploading documents w/Capital One

Non-investing personal finance issues including insurance, credit, real estate, taxes, employment and legal issues such as trusts and wills
Post Reply
User avatar
flamesabers
Posts: 1572
Joined: Fri Mar 03, 2017 12:05 pm
Location: Rochester, MN

Problem with uploading documents w/Capital One

Post by flamesabers » Mon Sep 18, 2017 10:20 am

Hello all.

Last week I applied for Capital One's Quicksilver rewards card. Since I have a fraud alert on my credit reports, Capital One has asked me to upload proof of my identity to their secure website. The problem is the website doesn't seem to be working for me. :(

After I upload the files, I click on the green submit button. The green button turns into a spinning circle (the tab for the website doesn't change though) but fails to go to a confirmation page that says Capital One has received my files. I tried submitting my files one at a time, but that only worked for one of my files and I haven't been able to repeat that success since. None of the files are too big to upload and they are all in the correct file format. I tried uploading my files on two different computers and three different browsers (Chrome, Firefox & Internet Explorer) with no success. I'm wondering if their website doesn't work on the weekends or something, but then, why would I get the email to upload my files late on Friday night? :confused

I'll be calling Capital One later today to find out what's going on, but I would like to know if anyone here has any feedback for me.

Post Reply